Search found 30 matches

by RoboBill
Thu Sep 28, 2017 12:47 am
Forum: MegunoLink
Topic: Unable to set data to send back to the UI
Replies: 8
Views: 4405

Unable to set data to send back to the UI

I'm using VS2015 and because of my sketch size, I've split the single ino file into 6. I'm trying to set the background color of a button based on an arduino variable. I can declare the following: InterfacePanel Panel; // The VS editor accepts this enty But Panel.set blah blah blah //The VS editor o...
by RoboBill
Tue Sep 26, 2017 11:45 pm
Forum: MegunoLink
Topic: Polar Plotting
Replies: 2
Views: 2048

Re: Polar Plotting

I finally got around to making a "polar plot". xy polar plot.PNG My "eye" is a LIDAR Lite V2 mounted on a Alex Moss controlled gimbal motor. It works great and is only there so my robot won't run into anyone. Its main guidance is a POZYX system. With robotic "what's around me" now affordable, having...
by RoboBill
Thu Jun 29, 2017 3:16 am
Forum: MegunoLink
Topic: Clearing a plot
Replies: 1
Views: 1280

Clearing a plot

I'm trying to clear a plot. I'm assuming I should use the Clear() command.

Trouble is, MYPLOT.Clear() is not recognized as a valid command.

Please tell me what I'm doing wrong.

Thanks

RoboBill
by RoboBill
Mon Jun 26, 2017 1:45 am
Forum: MegunoLink
Topic: Polar Plotting
Replies: 2
Views: 2048

Polar Plotting

Any chance of adding polar plotting to the time and XY plots. I'm using a LIDAR on my robot for obstacle avoidance.

Thanks,

RoboBill

otherwise I'll just calc it out on an xy ploy :cry:
by RoboBill
Fri Jun 23, 2017 8:34 pm
Forum: MegunoLink
Topic: Plotting with XBee
Replies: 1
Views: 1322

Re: Plotting with XBee

Found it!

added


TimePlot MyPlot("",XBeeSerial);

It works great! :mrgreen:
by RoboBill
Fri Jun 23, 2017 7:25 pm
Forum: MegunoLink
Topic: Plotting with XBee
Replies: 1
Views: 1322

Plotting with XBee

I can make the sinewave example work thru the standard serial port. But when I modify the sketch for an XBee series 1 on pins 8 & 11, I'm unable to see any plot data. What must I do to the arduino sketch to have the XYPlot data sent via my XBee. Thanks RoboBill Here is your example sketch with my So...
by RoboBill
Wed May 10, 2017 8:05 pm
Forum: MegunoLink
Topic: SoftwareSerial example
Replies: 6
Views: 3040

Re: SoftwareSerial example

Finally!!! The problem (yep all me) was I was using the Blink interface as it was downloaded from your site. Thanks to your last message, I first manually sent the !OnTime 50\r\n command via the XBee connection to confirm the SoftwareSerial connection and, sure enough the blink changed. So then I mo...
by RoboBill
Tue May 02, 2017 11:17 pm
Forum: MegunoLink
Topic: SoftwareSerial example
Replies: 6
Views: 3040

Re: SoftwareSerial example

Hi Phil, Thanks for that example and the links to the CommandHandler you emailed to me. Very informative. Unfortunately I still am unable to change the interval and duration. I am using XBee Series 1 as a simple serial connection Here is the code I am using: #include "CommandHandler.h" // The serial...
by RoboBill
Sun Apr 23, 2017 6:02 am
Forum: MegunoLink
Topic: SoftwareSerial example
Replies: 6
Views: 3040

Re: SoftwareSerial example

Hi Phil, To begin, I'm simply trying to plot several encoders data and to have a simple switch to stop the robot if it looks like its going to crash :oops: So now I've changed back over to XBee series 1 since I'm just talking between one computer and one arduino. Also because the Arduino code for XB...
by RoboBill
Sat Apr 22, 2017 4:06 pm
Forum: MegunoLink
Topic: SoftwareSerial example
Replies: 6
Views: 3040

SoftwareSerial example

Does anyone have any working examples of using SoftwareSerial?

Thanks

RoboBill