Search found 312 matches

by philr
Sun Apr 23, 2017 4:12 am
Forum: MegunoLink
Topic: XBee 2 data pins
Replies: 10
Views: 3635

Re: XBee 2 data pins

Excellent, hope it helps.
by philr
Sun Apr 23, 2017 4:11 am
Forum: MegunoLink
Topic: SoftwareSerial example
Replies: 6
Views: 2686

Re: SoftwareSerial example

Hi Bill, what part of the library do you want an example of?
by philr
Sun Apr 23, 2017 3:32 am
Forum: MegunoLink
Topic: How to set default item within value list?
Replies: 4
Views: 1975

Re: How to set default item within value list?

I don't believe it will. Thats the only problem with the default. You might be better to have a "get current state" button that gets clicked (by the user) before anything else. It could update all the UI to be correct before anything gets adjusted.
by philr
Wed Apr 12, 2017 4:10 am
Forum: MegunoLink
Topic: How to set default item within value list?
Replies: 4
Views: 1975

Re: How to set default item within value list?

Hi, this is now possible in the latest update.

Cheers
Phil
by philr
Tue Apr 04, 2017 5:34 am
Forum: MegunoLink
Topic: XBee 2 data pins
Replies: 10
Views: 3635

Re: XBee 2 data pins

Hi Bill, that code is in one of our examples. The arduino program is called MultiSourceCommandHandler.ino. It allows you to have multiple sources triggering a single set of commands. Our library is typically installed inside the libraries folder of your Arduino IDE. In my case it is in "\arduino-1.8...
by philr
Mon Apr 03, 2017 11:07 am
Forum: MegunoLink
Topic: XBee 2 data pins
Replies: 10
Views: 3635

Re: XBee 2 data pins

Hi, this example shows our command handler using multiple sources https://github.com/Megunolink/MLP/blob/master/examples/InterfacePanel/MultiSourceCommandHandler/MultiSourceCommandHandler.ino I think you could replace CommandProcessor<> Serial2CommandHandler(CommonCommands, Serial2); with CommandPro...
by philr
Sun Apr 02, 2017 6:00 am
Forum: MegunoLink
Topic: Result preview does not show correctly
Replies: 13
Views: 5651

Re: Result preview does not show correctly

Paul has asked if you have the latest .net framework installed?
https://www.microsoft.com/net/download/framework

Can you verify you have 4.6.2 installed?
by philr
Fri Mar 31, 2017 7:14 am
Forum: MegunoLink
Topic: XBee 2 data pins
Replies: 10
Views: 3635

Re: XBee 2 data pins

We don't have any xbee examples and I don't have easy access of the hardware currently. I'll try my best to outline a scenario that I believe I have seen working. If you take two xbees and put them in serial adapters like these https://www.sparkfun.com/products/11812 And connect megunolink to both o...
by philr
Thu Mar 30, 2017 11:15 pm
Forum: MegunoLink
Topic: How to set default item within value list?
Replies: 4
Views: 1975

Re: How to set default item within value list?

Hi currently this is not possible. You could get your microcontroller to fill out the defaults at boot up or by clicking a button. We will add the ability to have a default in future versions.

Cheers
Phil
by philr
Thu Mar 30, 2017 12:37 am
Forum: MegunoLink
Topic: XBee 2 data pins
Replies: 10
Views: 3635

Re: XBee 2 data pins

Hi RoboBill, MegunoLink talks to the modules using their API packet format natively so you can plug them straight into an xbee adapter with a COM port and talk to them using our xbee visualiser. If you are using it through an arduino you would need to read the xbee using software serial or a second ...