Problem with UDP and MegunoLink Host Builder

Support forum for MegunoLink
Post Reply
tabbiati
Posts: 4
Joined: Wed Nov 01, 2017 12:32 pm

Sun Dec 31, 2017 12:27 pm

Hi,

i have a problem with MegunoLink Host Builder and my project that use UDP; in MegunoLink al working ok but when i create and install package from it is impossible use connect button (like it is not working).
Any suggestion?

Thanks
rsfoto
Posts: 36
Joined: Mon Nov 20, 2017 12:09 am

Sun Dec 31, 2017 11:59 pm

Hi,

Did you connect the hardware to the PC you want to start ?
regards Rainer

Observatorio Real de 14, SLP, MEX
tabbiati
Posts: 4
Joined: Wed Nov 01, 2017 12:32 pm

Mon Jan 01, 2018 10:29 am

Hi,

thanks for reply; yes the problem there is only with packet build with Host Builder and all is ok in MegunoLink.

Thanks
philr
Posts: 279
Joined: Mon May 26, 2014 10:58 am

Mon Jan 01, 2018 8:04 pm

Yep there is a bug. Should be fixed in the next update. Hopefully today or tomorrow.

Phil
philr
Posts: 279
Joined: Mon May 26, 2014 10:58 am

Tue Jan 02, 2018 2:48 am

Connecting should now work.
Phil
tabbiati
Posts: 4
Joined: Wed Nov 01, 2017 12:32 pm

Tue Jan 02, 2018 2:14 pm

Hi Philip,

Problem with UDP now is solved as You says; adjust IP address would be very usefull but for now i don't use it.

Now i have another problem: series propriety in chart, when i build a package with Host Builder aren't the same that i have set in MegunoLink and if i set in application setting is lost between two session of use; this also i flag autosave in builder or save button.

Sorry for my poor English
philr
Posts: 279
Joined: Mon May 26, 2014 10:58 am

Sat Jan 06, 2018 11:07 pm

I'll post my email here too so everyone knows a solution for this. There is indeed a bug which will be fixed going forward but a better solution is to include the style information in the plotting message.

Hi Tullio, I tested it here and you're right it does seem to default to the same style. I suggest you modify your plotting messages to include the series properties you want.

For example
{TIMEPLOT|DATA|Cosinewave:bo-3|T|0.59}
{TIMEPLOT|DATA|Sinewave:ro-3|T|-0.36}

notice the ":bo-3" and ":ro-3"
These set the series to be blue (b) and red (r) with dashed line and circle markers.

See this page for the different styles etc
https://www.megunolink.com/documentatio ... reference/

Our Arduino library makes this even easier to build the right messages. This page has the detail
https://www.megunolink.com/documentatio ... reference/

Cheers
Phil
Post Reply