Just Weird!

Support forum for MegunoLink
Post Reply
hugh
Posts: 14
Joined: Sat Dec 31, 2016 4:59 pm

Mon Jan 07, 2019 3:57 pm

I have open two Monitor visualisers. I am trying to send a command string ~dgs#
I can enter this in the textbox on the bottom of the visualiser but as soon as I hit Send, it changes to ~dgS# - i.e. the case of the s chis changed from lower to upper case. If I add an extra lower case 's', sending ~dgss# it works perfectly but as soon as I remove one of the lower case s and send it reverts to sending ~dgS#. This is a big problem for me as I have coded all my command strings to be case-sensitive! I get the same behaviour from both
monitor panels.

Any thoughts?

Regards, Hugh
philr
Posts: 279
Joined: Mon May 26, 2014 10:58 am

Mon Jan 07, 2019 5:58 pm

Hi Hugh, this is an autocomplete problem. I think if you right click on the text bar it will let you remove previously entered commands.

Do you want to use both lower and upper case versions of the same command? If so I think we will need to change the way this works in a future update.

Cheers
Phil
hugh
Posts: 14
Joined: Sat Dec 31, 2016 4:59 pm

Tue Jan 08, 2019 1:07 pm

Hi Phil,

Thanks for the explanation.

Yes - I definitely want to use both cases - i.e. dss is a different command to dsS or dSs.
I have written all my software assuming this is so, so an update would be very welcome.

Regards, Hugh
philr
Posts: 279
Joined: Mon May 26, 2014 10:58 am

Wed Jan 09, 2019 8:42 am

Sounds like case sensitive isn't possible for that control. Best we could do is disable autocomplete. Would that work for you?

Cheers
Phil
Post Reply