New User Rob153

Share your projects using MegunoLink Pro here!
Post Reply
rob153
Posts: 4
Joined: Sat May 30, 2015 10:41 pm
Location: Seligman AZ 86337

Tue Jun 02, 2015 9:27 pm

I have a project I built, it's a Natural Electomagnetic Detector. I am trying to use a MegunoLink Pro for a visual interface.
This is a very long wave device 0 to 20 HZ. It has an analog signal input of 3.5 mV . I have a Seeed Studio SD card Shield, it all
installed well. I am using an Arduino Uno and have compiled a random seed program to monitor the analog signal. I was trying
connect my MegunoLink and am having problems with my Serial connect. Can any one help

Thanks Rob153
philr
Posts: 276
Joined: Mon May 26, 2014 10:58 am

Fri Jun 05, 2015 7:13 am

Hi Rob, let me know if you still keep having trouble. It sounds like windows i giving you grief when installing the serial driver.

Phil
rob153
Posts: 4
Joined: Sat May 30, 2015 10:41 pm
Location: Seligman AZ 86337

Mon Jun 22, 2015 4:33 am

Phil
I got the connection manager working fine, Thanks. I am having a problem with Time Plot . When I verify Class Time Plot
it said, has no member SetXlable or SetYlable . This is an example program, can you help?

Rob153
philr
Posts: 276
Joined: Mon May 26, 2014 10:58 am

Wed Jun 24, 2015 2:38 am

Hi Rob, is that a simple typo?
Lable rather than label

or does that happen with the raw timeplot example? What hardware, Arduino IDE version, and operating system are you using?

Cheers
Phil
rob153
Posts: 4
Joined: Sat May 30, 2015 10:41 pm
Location: Seligman AZ 86337

Sat Jun 27, 2015 5:17 pm

Hi Philr
I got your post and checked for spelling, it was not the problem. I am using the example program from MegunoLink . I did manage to load the cosine program.
Question, is there a sequence to follow with these example programs? Are there certain programs that must upload to work? I did get X Y Plot to upload and it works.
I installed 1.6.4 Windows 7 .
Thank You
Rob153
philr
Posts: 276
Joined: Mon May 26, 2014 10:58 am

Thu Jul 23, 2015 10:47 pm

Nice work! No there is not really a sequence that should be followed. The most important part is that the messages are formatted correctly (which they should be in the examples.. hopefully). Once they come in correctly MegunoLink will receive and process them using a particular visualiser. Some common issues are-

- Not selecting the correct channel in the message monitor or plotting windows
- Typo mistakes in the messages.

Let me know if you have any other issues or suggestions.
Cheers
Phil
rob153
Posts: 4
Joined: Sat May 30, 2015 10:41 pm
Location: Seligman AZ 86337

Thu Aug 06, 2015 5:44 am

Hi Phil
I got a serial connect and the Uno is working. My problem now is control. How do I change from one program to another?
I installed Time Plot, Plot Analog Value and XY Plot, Plot Analog Value and I see data in my monitor but no xy Plot or Time Plot.
I also have AnaloginOut Serial installed.
Rob153
philr
Posts: 276
Joined: Mon May 26, 2014 10:58 am

Tue Sep 08, 2015 11:37 pm

Hi Rob, did you have any luck getting data into your plotting windows?

Cheers
Phil
Post Reply