Search found 30 matches

by RoboBill
Tue Oct 31, 2017 1:31 pm
Forum: MegunoLink
Topic: Multiple SoftwareSerials connections
Replies: 3
Views: 1124

Re: Multiple SoftwareSerials connections

Well it turns out that only one SoftwareSerial port can "listen" at any given time. So if the program was listening to the Pixhawk/fcboardserial port, it would never receive any data from my XBee/Megunolink interface panel port. There is the SoftwareSerialPort.listen() function, but given that I'm n...
by RoboBill
Mon Oct 30, 2017 4:31 am
Forum: MegunoLink
Topic: Multiple SoftwareSerials connections
Replies: 3
Views: 1124

Multiple SoftwareSerials connections

I'm using Megunolink to monitor and (hopefully) adjust variables of a modified version of this sketch https://github.com/ArduPilot/ardupilot/blob/master/Tools/Pozyx/IndoorLoiter/IndoorLoiter.ino . I connect Megunolink to the Arduino Uno sketch via a standard XBee shield and using SoftwareSerial "XBe...
by RoboBill
Thu Oct 05, 2017 2:41 am
Forum: MegunoLink
Topic: InterfacePanel com port
Replies: 3
Views: 1559

Re: InterfacePanel com port

That was my first approach. But since I'm not a programmer, I had no clue what &rDestination = Serial really meant. But I did see how you did the XYPLOY stuff, so I figured you probably would do the same for interfacepanel.

Just got lucky :D

RoboBill
by RoboBill
Thu Oct 05, 2017 12:06 am
Forum: MegunoLink
Topic: InterfacePanel com port
Replies: 3
Views: 1559

Re: InterfacePanel com port

Wow... Took a guess and figured this one out too. Couldn't find any docs on this though

InterfacePanel Panel("Panel_Message", Serial2);

RoboBill
by RoboBill
Wed Oct 04, 2017 11:19 pm
Forum: MegunoLink
Topic: InterfacePanel com port
Replies: 3
Views: 1559

InterfacePanel com port

I assume that the Interfacepanel wants the Arduino to communicate with the UI via the Serial port.

But how do I change that port to Serial2?


Thanks

RoboBill
by RoboBill
Wed Oct 04, 2017 11:16 pm
Forum: MegunoLink
Topic: Unable to set data to send back to the UI
Replies: 8
Views: 3194

Re: Unable to set data to send back to the UI

OK as usual, I think I found the error. I needed to put the "Interfacepanel" in the global area. Now VS accepts the Panel.set blah blah

Thanks for your patients

RoboBill
by RoboBill
Mon Oct 02, 2017 8:57 am
Forum: MegunoLink
Topic: Unable to set data to send back to the UI
Replies: 8
Views: 3194

Re: Unable to set data to send back to the UI

Hi Paul, Thanks for the explanation. When I split the large program file into multiple files, I kept the global variable declarations, the setup() and loop() in the "main" file. All called functions were grouped in numerous multiple files. I didn't add any "#include other files "stuff in the main fi...
by RoboBill
Sun Oct 01, 2017 10:11 pm
Forum: MegunoLink
Topic: Unable to set data to send back to the UI
Replies: 8
Views: 3194

Re: Unable to set data to send back to the UI

To begin, I am using VisualMicro Pro with VS 2015. My first step to better understand this problem was to run the MLP example: Data Receiver Demo by itself... No problem there. Next I put the following lines from the MLP example into a single file version of my current code. // Progress value int Pr...
by RoboBill
Sun Oct 01, 2017 1:56 pm
Forum: MegunoLink
Topic: Unable to set data to send back to the UI
Replies: 8
Views: 3194

Re: Unable to set data to send back to the UI

Since I'm not a programmer, I don't know what build tool I'm using. I'm also not comfortable sending out my code. Since its well over a thousand lines, I'll step aside and work with a simple sketch then work it into the main code.

I'll keep you in the loop.

Thanks

RoboBill
by RoboBill
Sat Sep 30, 2017 11:43 pm
Forum: MegunoLink
Topic: Unable to set data to send back to the UI
Replies: 8
Views: 3194

Re: Unable to set data to send back to the UI

After declaring the InterfacePanel Control_Panel

I can use Control_Panel again in the Setup as noted here
SetupCodeError.jpg
SetupCodeError.jpg (242.63 KiB) Viewed 3175 times

But VS will not allow me to put Control_Panel in the loop as shown here:
LoopCodeError.jpg
LoopCodeError.jpg (100.62 KiB) Viewed 3175 times


Thanks

RoboBill