new compiling errors

Support forum for MegunoLink
Post Reply
GOHO
Posts: 12
Joined: Thu Dec 24, 2020 10:42 pm

Mon Nov 22, 2021 7:22 pm

Hi, earlier this year i built a project using my arduino, pressure sensor and the megunolink to measure and monitor a pressurized tank and it worked great. Recently i built another pressure tester and i tried to compile the exact same code into the sensor and it errors from the megunolink library. Has something changed in the driver that would cause a sketch from say march to not compile?
GOHO
Posts: 12
Joined: Thu Dec 24, 2020 10:42 pm

Mon Nov 22, 2021 7:37 pm

arduino error 1.png
arduino error 1.png (102.37 KiB) Viewed 162 times
arduino error 2.png
arduino error 2.png (113.84 KiB) Viewed 162 times
this sketch always compiled without issue, now it errors.
Paul
Posts: 30
Joined: Wed Jun 10, 2015 10:35 pm

Tue Nov 23, 2021 11:25 pm

Hi Goho,

I noticed you also have a library called "Time-master" in the build output. My guess is that there is a conflict with that library and the built-in "time.h" library we are using. That could happen if the "Time-master" library has a file named "time.h" too (it could override the system one).

To resolve, you could rename time.h in the time-master library to something else, propagating that change to any #includes in other files in the time-master library. I found a few Arduino time libraries so I'm not sure which one you are using. If you could post a link to it we might be able to figure out a different solution.

It looks like support for sending time values with our plotting library was made in January this year. So likely is the problem.

Have a good day
Paul.
GOHO
Posts: 12
Joined: Thu Dec 24, 2020 10:42 pm

Wed Nov 24, 2021 5:08 pm

thanks, ill check that but it didn't error before so im thinking maybe an updated library was the issue.

I have a pressure tester that is working right now using that exact code but now it wont compile....
GOHO
Posts: 12
Joined: Thu Dec 24, 2020 10:42 pm

Wed Nov 24, 2021 5:13 pm

thinking what might have changed, the only thing i updated since i last compiled this sketch was Megunolink. i have not updated the Arduino IDE or and library so the issue must be in an update from Megunolink.
GOHO
Posts: 12
Joined: Thu Dec 24, 2020 10:42 pm

Thu Nov 25, 2021 6:01 pm

i updated the Time library and it compiles ok. Problem solved!
Post Reply