XBee unable to get remote

Support forum for MegunoLink
Post Reply
User avatar
RoboBill
Posts: 30
Joined: Mon May 23, 2016 4:13 pm

Sat Dec 10, 2016 7:42 pm

I'm able to use XCTU to connect to both my coordinator XBee S2 and S2 end device. Highlighting the coordinator, XCTU can successfully discover the end device.

But after I disconnect from XCTU, I try the same with megunolink. I'm unable to retrieve remote settings of the end device. I'm able to connect to the coordinator. I'm able to use the node discovery and it successfully identifies the remote xbee. But when i try to get the remote xbee info, I get

Error retrieving Remote settings - VR timed out at (time of error)

What did I do wrong.

Thanks

RoboBill
admin
Site Admin
Posts: 14
Joined: Mon May 26, 2014 10:53 am

Tue Dec 20, 2016 4:15 am

Hi RoboBill, did you have it set to add escaped characters?

From our documentation
"MegunoLink expects recieved packets to have escaped characters added. Your XBees should have escaped characters set to yes (AP = 2 if using XCTU to configure the XBee). Check out the article called Escaped characters and API Mode 2 on the Digi website for more information on escape characters."

Another problem I have seen is the API Output Mode. I think it should be set to Native.

Let me know if any of those settings help.

Cheers
Phil
User avatar
RoboBill
Posts: 30
Joined: Mon May 23, 2016 4:13 pm

Wed Dec 21, 2016 1:31 am

That did it. Under modem interfacing options, I set the API Enable =2.

Thanks!!
User avatar
RoboBill
Posts: 30
Joined: Mon May 23, 2016 4:13 pm

Thu Dec 22, 2016 2:44 am

And yes, the API Mode is set to Native
Post Reply