Unable to connect to Arduino Mega 2560 via USB

Support forum for MegunoLink
Post Reply
Posts: 1
Joined: Wed Aug 21, 2019 10:23 am

Wed Aug 21, 2019 10:39 am

I've been working on my project the last few days and everything worked fine. I am using Megunolink as a GUI to create input via buttons and value lists to control my device.
Till yesterday I got no problems, but when I tried to connect Megunolink today, it wasn't possible to establish a serial connection.
The "connect" button did nothing. And when pressing some Buttons, I get the message "Error sending: can't write to serial channel. Is it open?"
Uploading my programs with the Arduino IDE works as usual. (I tried different programs)

When opening a backup .mlpz-File from yesterday, the connection is established and everything works as intended. But when disconnect once, I am not able to reconnect.
After loading the backup file again it works till the next disconnect.
Posts: 279
Joined: Mon May 26, 2014 10:58 am

Sat Aug 24, 2019 2:56 am

Hi, do you have a MegunoLink license? Those are the sort of symptoms you get when an invalid license key is used. Get in touch with use as support@megunolink.com with your transaction information and we can try to figure out what the issue is.

Post Reply