Error compiling example: WiFiTCPBlink [Solved]

Support forum for MegunoLink
Post Reply
mprowe
Posts: 2
Joined: Thu Jan 21, 2021 11:30 am

Thu Jan 21, 2021 11:47 am

First steps with Meguno....

But not a good start ... This is the Arduino copilation output.

Code: Select all

Arduino: 1.8.13 (Linux), Board: "ESP32 Dev Module, Disabled, Default 4MB with spiffs (1.2MB APP/1.5MB SPIFFS), 240MHz (WiFi/BT), QIO, 80MHz, 4MB (32Mb), 921600, None"
//////////// truncated for brevity  /////////////////
/home/mprowe/Arduino/libraries/MegunoLink/TCPCommandHandler.h:95:3: error: no return statement in function returning non-void [-Werror=return-type]
   }
   ^
/home/mprowe/Arduino/libraries/MegunoLink/TCPCommandHandler.h: In member function 'virtual size_t TCPCommandHandler<MAX_CONNECTIONS, MAX_COMMANDS, CP_SERIAL_BUFFER_SIZE, MAX_VARIABLES>::write(const uint8_t*, size_t)':
/home/mprowe/Arduino/libraries/MegunoLink/TCPCommandHandler.h:107:3: error: no return statement in function returning non-void [-Werror=return-type]
   }
   ^
cc1plus: some warnings being treated as errors
Multiple libraries were found for "WiFi.h"
 Used: /home/mprowe/.arduino15/packages/esp32/hardware/esp32/1.0.4/libraries/WiFi
 Not used: /opt/arduino-1.8.13/libraries/WiFi
Using library WiFi at version 1.0 in folder: /home/mprowe/.arduino15/packages/esp32/hardware/esp32/1.0.4/libraries/WiFi 
Using library ESPmDNS at version 1.0 in folder: /home/mprowe/.arduino15/packages/esp32/hardware/esp32/1.0.4/libraries/ESPmDNS 
Using library MegunoLink at version 1.25 in folder: /home/mprowe/Arduino/libraries/MegunoLink 
exit status 1
Error compiling for board ESP32 Dev Module.
Suggestions please.

Regards, M.
philr
Posts: 372
Joined: Mon May 26, 2014 10:58 am

Sat Jan 23, 2021 11:07 pm

Hi, we added a fix hopefully to our Arduino library. Please grab the latest files from github
https://github.com/Megunolink/MLP

And overwrite the ones on your computer then see if it fixes your issue.

Cheers
Phil
mprowe
Posts: 2
Joined: Thu Jan 21, 2021 11:30 am

Sun Jan 24, 2021 8:59 am

Thank you Phil (and of course all the other maintainers),

That worked a treat. I'm off to play....

Regards, M.

PS How do I mark this as "Solved"? I have added the text in the "Subject:" but that is not being reflected in the index?
philr
Posts: 372
Joined: Mon May 26, 2014 10:58 am

Tue Jan 26, 2021 7:42 am

Awesome, I've renamed the post.
Phil
Post Reply