Cannot change color of line in time plot

Support forum for MegunoLink
Post Reply
dpschwehr
Posts: 2
Joined: Tue Nov 10, 2015 4:19 am

Tue Nov 10, 2015 4:32 am

I have been trying to use the time plot example in the documentation->getting started->getting started with plotting data as a way to get acquainted with plotting data but have not been able to change the color of the plot lines. All lines are red no matter what parameters are sent to the SetSeriesProperties function ie MyPlot.SetSeriesProperties("Sinewave", Plot::Green, Plot::Solid, 2, Plot::Square); will only plot red plot lines.
Attachments
megunoFunk.png
megunoFunk.png (111.46 KiB) Viewed 7973 times
mtaufiq23
Posts: 5
Joined: Thu Oct 15, 2015 2:30 pm

Tue Nov 10, 2015 3:39 pm

Hi there, i have face these prob last week :oops: . To tell the truth, it took me 3 days to figure it out :cry: and the funny thing is, this can solve really easy. Im sure people like us overlook this thing.

To fix this, click the line in your plotted graph in timeplot window and go to the setting tab in the same timeplot window. From there, u can set the line setting as much as u need. Dont forget to save your GUI when u exit megunolink.

Thanks megunolink :lol:
dpschwehr
Posts: 2
Joined: Tue Nov 10, 2015 4:19 am

Wed Nov 11, 2015 6:46 pm

Following the above suggestions I was unable to find a "properties" for a line even after selecting a line. I was only able to find properties for the entire plot where I could change the color of the background and text.
mtaufiq23
Posts: 5
Joined: Thu Oct 15, 2015 2:30 pm

Mon Nov 16, 2015 1:36 pm

Sorry its in series properties. Select the line and click the series properties(the one with histogram icon).
Post Reply