UDP to MeguinoLink don't give connection

Support forum for MegunoLink
Post Reply
nils
Posts: 6
Joined: Sat Jun 12, 2021 10:16 am

Tue Nov 09, 2021 12:15 pm

Hi
I have used the setup from https://www.megunolink.com/articles/ard ... n-via-udp/
and downloaded to Teensy 4.1 https://github.com/PaulMartinsen/MLP-UDP-Example and Ipv4 address from ipconfig to set DestinationAddress
, but I don't get any response.
When I try Examples > NativeEthernet >Web client , it connects to a website (http://www.google.com) and gave : Received 7326044 bytes in 2.4486, rate = 133.16 kbytes/second
What is wrong with my setup? I have not connected the ADC.
in the setup I been trying:
Udp.begin(LocalPort);
Udp.beginPacket(DestinationAddress, DestinationPort);
Udp.print("Hallo");
Udp.endPacket();
It don't give any respons.

Maybe an amateur problem, I will happy if anyone can help me.

Nils
nils
Posts: 6
Joined: Sat Jun 12, 2021 10:16 am

Fri Nov 12, 2021 9:01 am

I give up, probably it was a stupid question from a stupid guy.
All of the MeguinoLink is working fine, having a lot of useful tools and the Host Builder is very nice, but I need ethernet communication.
Is it possible to buy some help ?

Nils
philr
Posts: 401
Joined: Mon May 26, 2014 10:58 am

Fri Dec 03, 2021 11:33 pm

Hi Nils, I dont know much about that hardware but did you try this example out?
https://github.com/vjmuzik/NativeEthern ... String.ino

It looks like you would need to then put the IP address of your teensy into megunolink and send it a message. It will then print it to the teensy serial port which you could also view in megunolink and it will send a message back over UDP to the computer you sent the message from. Megunolink should be able to display the acknowledgement message as well.

Good luck!
Post Reply